Javelo SSO login issues

Incident Report for Tellent

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 15:26 UTC

Investigating

Some Javelo users have been experiencing login related issues, impacting ability to log with SSO. We understand this is frustrating, and our technical team is actively investigating it to restore full functionality as soon as possible.
Posted Feb 11, 2026 - 15:03 UTC
This incident affected: Tellent HR / Grow (Javelo) (Grow API).