Recruitee & Careers not loading

Incident Report for Tellent

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 06:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 07, 2025 - 06:25 UTC

Investigating

The Recruitee platform is currently experiencing loading issues, which may be causing pages not to load, unresponsive, or to show connectivity issues. We understand this is frustrating, and our technical team is actively investigating it to restore full functionality as soon as possible.
Posted Aug 07, 2025 - 06:11 UTC
This incident affected: Tellent Recruitee (Recruitee API, Recruitee Careers Sites).