Email Receiving and Sending Issues
Incident Report for Tellent
Resolved
This incident has been resolved.
Posted May 27, 2024 - 14:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 27, 2024 - 14:03 UTC
Identified
We are currently experiencing issues with our email provider, which is preventing emails from being received or sent from our system. We will update you on the progress and notify you once the issue is resolved.
Posted May 27, 2024 - 13:52 UTC
This incident affected: Recruitee (Recruitee Website).