Tellent company email service disruption

Incident Report for Tellent

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 14:12 UTC

Monitoring

We're back; the Tellent company email service is operational, and we are monitoring it.
Posted Jul 09, 2025 - 14:50 UTC

Update

The issue has been escalated to the email provider, and we're actively collaborating with their support team to help resolve the ongoing disruption to our email service. Tellent employees are still unable to send and receive emails at the @tellent.com domain. While the root cause lies within the external email infrastructure, we’re closely monitoring the situation and doing everything we can on our end. Thank you for your continued patience — we’ll provide more updates as they become available.
Posted Jul 08, 2025 - 17:36 UTC

Update

We are continuing to investigate this issue.
Posted Jul 08, 2025 - 12:16 UTC

Investigating

We’re currently experiencing an issue with our email service. At the moment, Tellent employees are unable to send and receive emails at the @tellent.com domain. Our team is actively investigating the problem and working to resolve it as quickly as possible. We’ll share updates as soon as we have more information.
Posted Jul 08, 2025 - 12:12 UTC