Issues with marketing site
Incident Report for Tellent
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 22:34 UTC
Investigating
We are currently experiencing issues with our marketing site provider. Some users might experience issues loading https://recruitee.com website. In order to access our application, please navigate directly to https://app.recruitee.com
Posted Sep 06, 2024 - 20:26 UTC
This incident affected: Recruitee (Recruitee Website).