Recruitee & Careers slow to respond

Incident Report for Tellent

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 13:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 12:50 UTC

Investigating

The Recruitee platform is currently experiencing performance issues, and may be causing pages to be slow, unresponsive, or showing connectivity issues. We understand this is frustrating, and our technical team is actively investigating it to restore full functionality as soon as possible.
Posted Apr 16, 2025 - 12:38 UTC
This incident affected: Tellent Recruitee (Recruitee API, Recruitee Careers Sites).