Recruitee mailbox issues

Incident Report for Tellent

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 10:23 UTC

Identified

The issue was identified and we are working closely with 3rd party provider for quick resolution
Posted Mar 17, 2025 - 10:10 UTC

Investigating

Some Recruitee users have been experiencing mailbox related issues, impacting ability to send or recieve emails. We understand this is frustrating, and our technical team is actively investigating it to restore full functionality as soon as possible.
Posted Mar 17, 2025 - 10:08 UTC
This incident affected: Recruitee (Recruitee Mail Connector).